I'm using the latest Pd release (the P4 optimised version) on WinXP.
If you have a $0- in a subpatch name and change the subpatch name
after the fact, the subpatch's name (in the titlebar) appears blank. This also prevents any messages being sent to that subpatch by name (like "; pd-$0-subpatch vis 1").
It does reinitialise itself if you close/re-open the patch.
Here's a little example of it not working:
#N canvas 511 110 397 315 10; #X obj 60 61 f $0; #X obj 29 110 pack f s; #X obj 29 19 tgl 15 0 empty empty empty 0 -6 0 8 -262144 -1 -1 0 1; #X msg 29 133 ; $2 vis $1; #X obj 62 39 loadbang; #X text 38 187 Try the toggle. Then change the subpatch name and try the toggle.; #X text 36 220 Don't forget to change the makefilename argument to match your changed subpatch name. (not that it's going to work any better); #N canvas 86 281 387 85 Pd 0; #X text 129 14 Look at my titlebar!; #X text 93 42 Change my name, the makefilename argument and then try the toggle.; #X restore 260 80 pd $0-subpatch; #X obj 60 81 makefilename pd-%d-subpatch; #X text 56 284 David McCallum , 8dngm@qlink.queensu.ca; #X connect 0 0 8 0; #X connect 1 0 3 0; #X connect 2 0 1 0; #X connect 4 0 0 0; #X connect 8 0 1 1;
. . David McCallum . Music wants to be free . http://mentalfloss.ca/sintheta/ .
Hi David and list,
I get the same behaviour. In case you're using the P4 optimized version from my website, this is 0.35-0 _not_ 0.35-1. I've tried it with Miller's official release (0.35-1), same result... As far as I remeber the only bugfix in 0.35-1 was for the 'find' function. Or should we try that one?
Olaf
David McCallum schrieb:
I'm using the latest Pd release (the P4 optimised version) on WinXP.
If you have a $0- in a subpatch name and change the subpatch name
after the fact, the subpatch's name (in the titlebar) appears blank. This also prevents any messages being sent to that subpatch by name (like "; pd-$0-subpatch vis 1").
It does reinitialise itself if you close/re-open the patch. Here's a little example of it not working:
#N canvas 511 110 397 315 10; #X obj 60 61 f $0; #X obj 29 110 pack f s; #X obj 29 19 tgl 15 0 empty empty empty 0 -6 0 8 -262144 -1 -1 0 1; #X msg 29 133 ; $2 vis $1; #X obj 62 39 loadbang; #X text 38 187 Try the toggle. Then change the subpatch name and try the toggle.; #X text 36 220 Don't forget to change the makefilename argument to match your changed subpatch name. (not that it's going to work any better); #N canvas 86 281 387 85 Pd 0; #X text 129 14 Look at my titlebar!; #X text 93 42 Change my name, the makefilename argument and then try the toggle.; #X restore 260 80 pd $0-subpatch; #X obj 60 81 makefilename pd-%d-subpatch; #X text 56 284 David McCallum , 8dngm@qlink.queensu.ca; #X connect 0 0 8 0; #X connect 1 0 3 0; #X connect 2 0 1 0; #X connect 4 0 0 0; #X connect 8 0 1 1;
. . David McCallum . Music wants to be free . http://mentalfloss.ca/sintheta/ .
PD-list mailing list PD-list@iem.kug.ac.at http://iem.kug.ac.at/cgi-bin/mailman/listinfo/pd-list
hi David (and the devs),
in case this has not been fixed with yet, and there has been no major redesign of the g_canvas.c or the $-code, maybe this patch could be of some help? Or maybe the canvas_rename() itself should be given an atom pointer argument, instead of a symbol, in order to avoid code duplication?
+++ g_canvas.c Fri Oct 25 09:33:31 2002 @@ -1074,8 +1074,19 @@
static void canvas_rename_method(t_canvas *x, t_symbol *s, int ac, t_atom *av) {
canvas_rename(x, av->a_w.w_symbol, 0);
if (av->a_type == A_SYMBOL)
else if (av->a_type == A_DOLLSYM && x->gl_owner)
{
canvas_rename(x, realizedollsym(av->a_w.w_symbol,
e->ce_argc, e->ce_argv, 1), 0);
}
Krzysztof
David McCallum wrote: ...
If you have a $0- in a subpatch name and change the subpatch
name after the fact, the subpatch's name (in the titlebar) appears blank. This also prevents any messages being sent to that subpatch by name (like "; pd-$0-subpatch vis 1").