As hinted at in an earlier email (thanks for the help!), I have a new version of plugin~. It supports two new messages:
bind foo - listens for messages sent to foo-gain, foo-drive, etc. You can bind sliders, sssad objects, etc. to the same names and have everything just work.
bindscaled foo - the same, but translates messages from the 0-127 range into the range appropriate for that parameter (as defined by the ladspa plugin). If anyone has a pithier name for this message, I'm all ears.
I also went through and fixed several segfaults, mostly relating to messages sent without a plugin being loaded. Also, specifying a library file as a name without a full path now works whether or not LADSPA_PATH is defined.
I've posted my version at http://artdent.homelinux.net/publicsvn/plugin~/ . I've only tested it on Linux, as the SConstruct file needs some more work to be cross-platform and to integrate with the pd-extended scons scripts.
I'd be keen to see this get into the main svn repository (pending, of course, any fixes, improvements, etc). Should I make a patch file and add it to the patch tracker? Given the number of files involved, it might be easier to just check in the whole directory.
These extra messages have simplified some of my patches quite nicely; I hope they're useful to others in the same way.
(Also, side note to Thomas Grill: stupidly, I had been compiling flext from the (out-of-date) sourceforge repository. With the latest version from the correct repo, the autotools build works perfectly and does indeed require no more information than the path to the pd sources.)