-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1
On 01/21/2011 04:34 AM, david medine wrote:
so that the first line reads:
'current: pd_darwin'
how about calling make with "pd_darwin" instead? e.g. $ make would call the first target, whereas $ make pd_darwin would call the "pd_darwin" target directly.
then in the section that sets the rules and recipes for building on make it looks so:
'pd_darwin: $(NAME).pd_darwin
.SUFFIXES: .pd_darwin
DARWINCFLAGS = -DPD -O2 -Wall -W -Wshadow -Wstrict-prototypes
-Wno-unused -Wno-parentheses -Wno-switch.c.pd_darwin: $(CC) -arch i386 $(DARWINCFLAGS) $(LINUXINCLUDE) -o $*.o -c $*.c $(CC) -arch i386 $(LIBS) -bundle -undefined suppress -flat_namespace
-o $*.pd_darwin $*.o rm -f $*.o'I took out all the '.d_ppc' and '-arch ppc' stuff that's in the makefile that comes with Pd (vanilla) because I have an intel core so ppc junk is irrelevant.
irrelevant to you probably. other people might think differently (eg. i mostly think that mac is irrelevant)
I changed .d_fat to .pd_darwin, because somebody who actually knows stuff (unlike me) told me that .pd_darwin is the current convention.
whoever this person was, he told you wrong. while "pd_darwin" is supported, the current convention is "d_fat"
anyhow, rather than reinventing the wheel, i would suggest starting with the latest version of the template Makefile, as hans has suggested.
fgamsd IOhannes