This is all great feedback, guys - keep it coming. Keep in mind I'm still learning Tcl/Tk, so some of these ideas, while excellent, are a little beyond my technical grasp at this point and may be improvements that we make incrementally over time. Also, I have a limited amount of my time to budget for this kind of work - I also work full-time and make music too - so I think prioritizing some of these ideas into subsequent releases is probably the best way to get them into Pd.
Some points:
each list item, and also tried to look for a way to edit list items in place, but couldn't figure out how to make that work in Tcl/Tk, so I settled on the popup box. The bug you saw with that not working, Hans, I've since fixed.
wasn't wholly satisfied with it and found that it introduced more problems than it solved. For example, what if you select multiple Paths and then click "Edit"? What is that supposed to do?
really cool, but it seems like it's a lot more work to do that, since Tk's default listbox widget only wants to deal with arrays of strings.
removed everywhere and folded into "Apply" ("OK" does "Apply" + "Cancel"). I think what it originally was supposed to do was give you an opportunity to test settings without saving them, but for that, I think it's best to have something like a "Revert settings" button instead. Also, I think this functionality is so marginal that we can remove it altogether.
MIDI) should all be different tabs in the same dialog. However, that seems like a feature that can be added at a later time; for now, I'd like to focus on finishing up the improvements that we already have, so we can try & get them into Vanilla, then perhaps go through the menu system at some point and re-evaluate how that's structured, maybe do some further improvements with some of the other menus too. Plus I'm itching to get on to improving the UI widget settings boxes.
having everything keyboard-accessible, which includes stuff like tab order, so I think it's probably best to keep around the buttons for list editing commands for now, although we can certainly investigate ways to reduce the size they take up on the screen.
I'm going to spend some spare time over the next few days working out some of the remaining kinks, then I'll re-post the patch for review before submitting it to the tracker. Thanks again to everyone who has taken time to look at the proposed changes!
If anyone has specific ideas to improve the layout of these dialogs, it would be amazing to see some sort of low-fi sketch of what you have in mind, just black outlines with text on a white background would be fine. Also, if anyone has some more advanced Tk wizardry they'd like to impart, or could point me to some better resources, I'd be most grateful - Google has been a lot less helpful than I've experienced with other languages/platforms.
Thanks, David
On Sun, May 11, 2008 at 7:57 AM, Hans-Christoph Steiner hans@eds.org wrote:
Oops, one other detail with the "encode" proc. While namespaces are probably the current way to handle function names, they are not used for any other functions in u_main.tk So for this function, I think it should be called something like pdtk_encodelist without the namespace, then grouped with pdtk_encode. Something like this:
proc pdtk_encodelist {listdata} { set outlist {} foreach this_path $listdata { if {0==[string match "" $this_path]} { lappend outlist [pdtk_encodedialog $this_path] } } return $outlist }
Then perhaps namespaces can be introduced later as a more systematic approach.
.hc
On May 11, 2008, at 3:15 PM, Hans-Christoph Steiner wrote:
I just thought of one other thing: I think it would be very useful if Path, Startup, Audio Settings, and MIDI settings where all tabs in one panel, instead of four separate panels.
.hc
On May 11, 2008, at 1:29 PM, Hans-Christoph Steiner wrote:
Wow, what an improvement! I like it a lot. I have some comments:
- minor thing, maybe there could be less space on the sides, so the panel
would be narrower?
- about the Apply button, I think it should only show up on platforms
where it is a common thing. On Mac OS X, it should just be OK and Cancel. On Windows, there should be Apply. I think GNOME has moved away from Apply, but I don't know anything about KDE.
- some separation of the buttons on the right column would make things
clearer, I think. Like maybe Up/Down on the right side, and then Add..., Edit..., and Delete on the bottom? Or maybe just changing Up and Down to arrows?
- the startup thing is trickier. I think that the textfield for entering
values should be embedded into the panel instead of a popup. Also, it doesn't seem to work for me (I am using 0.41-4 vanilla). I can't add items to the list.
I think once this is worked out, the best plan would be to submit a patch to the tracker and assign it to Miller. Then I'll also include it in Pd-extended.
.hc
On May 11, 2008, at 2:25 AM, David Golightly wrote:
Just verified against my own install of Pd-extended-0.40.3 on OS X 10.4 - enough differences exist otherwise in the nightlies that this version of the file will only work with 0.41.4.
Attached is an updated (slightly bugfixed) version.
So... what's the procedure for checking in to svn :)?
-David
On Sat, May 10, 2008 at 4:24 PM, David Golightly davigoli@gmail.com wrote:
Well scratch that then, perhaps that will only work when you're building pd on your own machine. If you launch Pd from Terminal, you might see error output in that terminal window - that would be helpful to have.
On Sat, May 10, 2008 at 3:17 PM, marius schebella < marius.schebella@gmail.com> wrote:
I tried this with pd extended 0.40-3, but did not get a startup pref window at all and the path window was very small and empty. (os x, 10.5.) marius.
David Golightly wrote:
And, here's a version with an updated Startup dialog. Simply copy this to bin/pd.tk http://pd.tk (make a backup first!) to try it out.
On Sat, May 10, 2008 at 12:48 PM, David Golightly < davigoli@gmail.com mailto:davigoli@gmail.com> wrote:
On Sat, May 10, 2008 at 12:36 PM, Steffen Juul <stffn@dibidut.dk mailto:stffn@dibidut.dk> wrote:
On 10/05/2008, at 19.48, David Golightly wrote: Ok, after a busy week this is what I've been able to come
up with for the Path dialog.
Looking really good! The browse functionality is a fair idiom
in a such GUI as oppose to entering text, i think.
Thanks! I've often been kind of frustrated that I have to type in the full directory name rather than simply browsing to it. For the keyboard-inclined, however, text entry should still be possible.
"One" comment: I have a beef with the functionality of the buttons. Not the Cancel one. The others. 'Apply' does
something. 'Ok' does 'apply' plus 'cancel'. 'Save...' does 'Apply' plus saves. But it says the list is only gonna work from next time Pd is lunched, why i don't get the 'Apply' and 'Ok'. 'Ok' should do save and cancel. Thats all one wants, anit?
I agree. I've preserved the pre-existing functionality for those buttons from before, but do we really need both "Save" and "Apply"? Currently, "Save" also "saves preferences" (verbose & use standard extensions). I think that should also happen when you click "Apply", so we can do away with the "Save" button, and also make sure that the message about needing to restart PD pops up when you click "OK" or "Apply".
I'm thinking about adapting this UI for the Startup
dialog - shouldn't be hard to do - except instead of choosing directories you want to enter arbitrary text.
I haven't checked your code but i suppose most "proc's" can
be reused?
I've set up some various key bindings so I want to make
sure it seems usable for everyone.
Nice. What are they?
Default key bindings for the listbox widget give you "up" and "down" keys to select, I've added "Delete" to delete the current selection, and "Return" to open the browse dialog (same as pressing "Edit").
So far I've only tested this on Mac OS X OS X.4 here.
PD-list@iem.at mailing list UNSUBSCRIBE and account-management -> http://lists.puredata.info/listinfo/pd-list
<u_main.tk>_______________________________________________ PD-list@iem.at mailing list UNSUBSCRIBE and account-management -> http://lists.puredata.info/listinfo/pd-list
http://at.or.at/hans/
News is what people want to keep hidden and everything else is publicity. - Bill Moyers
"[W]e have invented the technology to eliminate scarcity, but we are deliberately throwing it away to benefit those who profit from scarcity." -John Gilmore