hi
i just noticed, that jamie has committed changes to the "cube"-Geos, to allow a [blend 1/0( message.
however, to avoid restarting this and to save everyone a lot of programming time, i would suggest: 1) using inheritance rather than putting the same piece of code in each Geo. 2) (more important): why not use [alpha] and [polygon_smooth] ? i think this has been discussed. [alpha] certainly needs more attention to make the blending-style-setting more consistent.
i don't think, that there is any performance-issue in this, and it could save us all (jamie) a lot of time...
mfg.as.rd IOhannes
ps:here is my last email regarding this, from 25/02/03:
chris clepper wrote:
and another two changes:
- [alpha]
now you can set the blending-function 0..GL_ONE_MINUS_SRC_ALPHA that's the (old) default 1..GL_ONE (as would be enabled by the "blend" message to various
objects.
perhaps we should add some of the other options for glBlend and allow
both the source and destination to be changed.
yes definitely. it was just done very quickly.
- [polygon_smooth]
enables polygon smoothing
the only difference i found is that [polygon_smooth] sets blending
for the entire render chain it's attached to while the "blend" method would actually work on individual objects in the same chain. it's probably not a big deal, and maybe not even a big feature to warrant keeping "blend". it's definitely easier to do the [polygon_smooth] rather than add glBlend to each Geo.
it enables aa'ing for everything that comes below the [polygon_smoothing]. Maybe we should just add a another state that disables aa'ing: suggestion: 1 .. enable smoothing 0 .. disbale smoothing -1 .. leave unchanged
i think [polygon_smooth] is a bad name. but which one would be better ?
still no suggestions for the name... maybe wrapping [alpha], [color]
well, yes it is not that bad. (at least better than [pix_a_2grey])
and [polygon_smooth] up in an abstraction called [geo_blend] would be
something to try?
;-)
mfg.ads.r IOhannes