Hallo,
I see, that linuxevent.c in CVS was changed to exclude EV_RST which isn't defined in newer input.h headers anymore. I wonder, if this is the correct way to solve this problem. input.h does define EV_SYN now as being zero:
/* * Event types */
#define EV_SYN 0x00 ...
I don't know what this event does and if it's important to still include them, but maybe someone else does? At least, just commenting out EV_RST feels a bit wrong...
ciao
Have you seen any docs on this change from EV_RST to EV_SYN? I searched and didn't find anything. I am wondering why the change happened. A stable API would sure be nice. What is EV_RST or EV_SYN anyway? It looks likely that EV_SYN is just a new name for EV_RST, so an #ifdef selecting one or the other would probably make the most sense.
.hc
On Saturday, Mar 20, 2004, at 08:50 America/New_York, Frank Barknecht wrote:
Hallo,
I see, that linuxevent.c in CVS was changed to exclude EV_RST which isn't defined in newer input.h headers anymore. I wonder, if this is the correct way to solve this problem. input.h does define EV_SYN now as being zero:
/*
- Event types
*/
#define EV_SYN 0x00 ...
I don't know what this event does and if it's important to still include them, but maybe someone else does? At least, just commenting out EV_RST feels a bit wrong...
ciao
Frank Barknecht _ ______footils.org__
PD-dev mailing list PD-dev@iem.at http://iem.at/cgi-bin/mailman/listinfo/pd-dev
Hallo, Hans-Christoph Steiner hat gesagt: // Hans-Christoph Steiner wrote:
Have you seen any docs on this change from EV_RST to EV_SYN? I searched and didn't find anything. I am wondering why the change happened. A stable API would sure be nice. What is EV_RST or EV_SYN anyway? It looks likely that EV_SYN is just a new name for EV_RST, so an #ifdef selecting one or the other would probably make the most sense.
Sound sensible. I have no idea, what SYN or RST mean. probably they just mean: "nothing happening here currently..."
We could ask on linux-usb-devel for details.
ciao
I was actually tempted to remove the EV_RST (its not handled, so what). But then I thought the #ifdef would be some sort of a warning that something actually has changed. In general everything should be "not handled" cleanly by the empyt default: switch.
Guenter
On Sun, 21 Mar 2004, Frank Barknecht wrote:
Hallo, Hans-Christoph Steiner hat gesagt: // Hans-Christoph Steiner wrote:
Have you seen any docs on this change from EV_RST to EV_SYN? I searched and didn't find anything. I am wondering why the change happened. A stable API would sure be nice. What is EV_RST or EV_SYN anyway? It looks likely that EV_SYN is just a new name for EV_RST, so an #ifdef selecting one or the other would probably make the most sense.
Sound sensible. I have no idea, what SYN or RST mean. probably they just mean: "nothing happening here currently..."
We could ask on linux-usb-devel for details.
ciao
Frank Barknecht _ ______footils.org__
PD-dev mailing list PD-dev@iem.at http://iem.at/cgi-bin/mailman/listinfo/pd-dev