Hey IOhannes,
I was just looking thru your pdwindow.tcl procs. It seems to me that those procs should just go all the way and implement a syslog-style system with the same levels. Then the Pd window could have a little dropdown menu on the lower left to select which level to show.
Attached is my failed attempt at defining the functions. Also, about the tags for colorizing things, I think your syslog level tags and the alternating linecolor? tags should be applied to all lines, not depending on which proc is used. Then different plugins or modes can colorize the text. Otherwise, it'll be just a big mishmash of colors.
As for me, I think just a subtle alternating color per post, not per- line. Then error posts would have a sublte red background.
.hc
----------------------------------------------------------------------------
'You people have such restrictive dress for women,’ she said, hobbling away in three inch heels and panty hose to finish out another pink- collar temp pool day. - “Hijab Scene #2", by Mohja Kahf
Hans-Christoph Steiner wrote:
Hey IOhannes,
I was just looking thru your pdwindow.tcl procs. It seems to me that those procs should just go all the way and implement a syslog-style system with the same levels. Then the Pd window could have a little dropdown menu on the lower left to select which level to show.
the pdwindow::verbose{} functionality is modelled after pd's verbose() functionality. assuming that most Pd devs will have more experience with Pd's posting mechanisms than with a platform depending syslog functionality, it made way more sense to use "verbose" than "syslog".
if the only reason to change the name to "syslog" is, that the mechanism reminds you remotely on that used by syslog, i would kindly ask to change it back.
Attached is my failed attempt at defining the functions. Also, about the tags for colorizing things, I think your syslog level tags and the alternating linecolor? tags should be applied to all lines, not depending on which proc is used. Then different plugins or modes can colorize the text. Otherwise, it'll be just a big mishmash of colors.
please bear in mind that english is not my mother tongue. ...oh, it seems like the "linecolor?" does not finish the sentence.
then, i don't see what you mean: the public functions are ::pdwindow::verbose{}, ::pdwindow::error{} & ::pdwindow::post{} are the public functions that all set the corresponding tags.
so my argueing is, that tags should be applied to all text (which they currently are), depending on which category a text belongs to. the category is given implicitly by the proc that is used to print the message. thus the tags are "depending on which proc is used".
what i did change was to only call the colorizing code for a tag once, and not each time something was printed. (which is somewhat useless and only adds additional ressources)
As for me, I think just a subtle alternating color per post, not per-line. Then error posts would have a sublte red background.
sure
fgmasdr IOhannes
On Jan 16, 2010, at 5:13 AM, IOhannes zmölnig wrote:
Hans-Christoph Steiner wrote:
Hey IOhannes,
I was just looking thru your pdwindow.tcl procs. It seems to me that those procs should just go all the way and implement a syslog-style system with the same levels. Then the Pd window could have a little dropdown menu on the lower left to select which level to show.
the pdwindow::verbose{} functionality is modelled after pd's verbose() functionality. assuming that most Pd devs will have more experience with Pd's posting mechanisms than with a platform depending syslog functionality, it made way more sense to use "verbose" than "syslog".
if the only reason to change the name to "syslog" is, that the mechanism reminds you remotely on that used by syslog, i would kindly ask to change it back.
While there is a verbose() function defined in s_print.c, it is literally never used in the pd source. That's why I changed the name, I didn't realize verbose() existed. It is used lightly in some externals. If you really want it to be called verbose(), go for it.
Attached is my failed attempt at defining the functions. Also, about the tags for colorizing things, I think your syslog level tags and the alternating linecolor? tags should be applied to all lines, not depending on which proc is used. Then different plugins or modes can colorize the text. Otherwise, it'll be just a big mishmash of colors.
please bear in mind that english is not my mother tongue. ...oh, it seems like the "linecolor?" does not finish the sentence.
linecolor? is the tag name, ie linecolor0, linecolor1. I think the tag should be renamed alternatingpost0, alternatingpost1 and have it based on post rather than line.
then, i don't see what you mean: the public functions are ::pdwindow::verbose{}, ::pdwindow::error{} & ::pdwindow::post{} are the public functions that all set the corresponding tags.
so my argueing is, that tags should be applied to all text (which they currently are), depending on which category a text belongs to. the category is given implicitly by the proc that is used to print the message. thus the tags are "depending on which proc is used".
what i did change was to only call the colorizing code for a tag once, and not each time something was printed. (which is somewhat useless and only adds additional ressources)
IIRC, one function was posting with the linecolor0/1 tags and the other with the verbose/syslog style tags. I am saying all posts should have both a linecolor/alternatingpost tag and a verbose/syslog level tag.
.hc
As for me, I think just a subtle alternating color per post, not per-line. Then error posts would have a sublte red background.
sure
fgmasdr IOhannes
----------------------------------------------------------------------------
I have the audacity to believe that peoples everywhere can have three meals a day for their bodies, education and culture for their minds, and dignity, equality and freedom for their spirits. - Martin Luther King, Jr.
Quoting "Hans-Christoph Steiner" hans@at.or.at:
please bear in mind that english is not my mother tongue. ...oh, it seems like the "linecolor?" does not finish the sentence.
linecolor? is the tag name,
this became clear to me only afterwards. i thought "?" was meant as interpunctuation, not as wildcard.
ie linecolor0, linecolor1. I think the tag should be renamed alternatingpost0, alternatingpost1 and have it based on post rather than line.
IIRC, one function was posting with the linecolor0/1 tags and the other with the verbose/syslog style tags.
ah, no: one function was using the tag "errortext", another the tags "verbose?", and yet another used "linecolor?". for me, "linecolor?" represented "ordinary text", rather than "every other line, regardless of texttype".
I am saying all posts should have both a linecolor/alternatingpost tag and a verbose/syslog level tag.
makes sense. (the "verbose/syslog level tag" are rather "post", "error", "verbose?"; according to the Pd API)
gfmsar IOhannes
---------------------------------------------------------------- This message was sent using IMP, the Internet Messaging Program.
On Jan 17, 2010, at 1:31 PM, zmoelnig@iem.at wrote:
Quoting "Hans-Christoph Steiner" hans@at.or.at:
please bear in mind that english is not my mother tongue. ...oh, it seems like the "linecolor?" does not finish the sentence.
linecolor? is the tag name,
this became clear to me only afterwards. i thought "?" was meant as interpunctuation, not as wildcard.
ie linecolor0, linecolor1. I think the tag should be renamed alternatingpost0, alternatingpost1 and have it based on post rather than line.
IIRC, one function was posting with the linecolor0/1 tags and the other with the verbose/syslog style tags.
ah, no: one function was using the tag "errortext", another the tags "verbose?", and yet another used "linecolor?". for me, "linecolor?" represented "ordinary text", rather than "every other line, regardless of texttype".
I am saying all posts should have both a linecolor/alternatingpost tag and a verbose/syslog level tag.
makes sense. (the "verbose/syslog level tag" are rather "post", "error", "verbose?"; according to the Pd API)
Hmm, I am not sure it makes sense to have three systems (alternating, post/error, and verbosity level). How about just alternating and verbosity level, then assigning post and error a verbosity level?
.hc
----------------------------------------------------------------------------
Access to computers should be unlimited and total. - the hacker ethic
Quoting "Hans-Christoph Steiner" hans@at.or.at:
makes sense. (the "verbose/syslog level tag" are rather "post", "error", "verbose?"; according to the Pd API)
Hmm, I am not sure it makes sense to have three systems (alternating, post/error, and verbosity level). How about just alternating and verbosity level, then assigning post and error a verbosity level?
isn't that the same? just think as "error" and "post" as special and explicit verbosity levels.
this is really only modelled after Pd currently does things (which is not necessarily the worst thing)
fgamsrd IOhannes
---------------------------------------------------------------- This message was sent using IMP, the Internet Messaging Program.
On Jan 17, 2010, at 2:22 PM, zmoelnig@iem.at wrote:
Quoting "Hans-Christoph Steiner" hans@at.or.at:
makes sense. (the "verbose/syslog level tag" are rather "post", "error", "verbose?"; according to the Pd API)
Hmm, I am not sure it makes sense to have three systems (alternating, post/error, and verbosity level). How about just alternating and verbosity level, then assigning post and error a verbosity level?
isn't that the same? just think as "error" and "post" as special and explicit verbosity levels.
this is really only modelled after Pd currently does things (which is not necessarily the worst thing)
Ok, so how about these as the tags:
altline0 altline1
and:
log0 log1 log2 log3 log4 log5 log6 log7
then:
pd_error = log1 (Alert) error = log3 (Error) post = log5 (Notice)
.hc
----------------------------------------------------------------------------
News is what people want to keep hidden and everything else is publicity. - Bill Moyers