On Mar 13, 2008, at 3:07 PM, mescalinum@gmail.com wrote:
Hans-Christoph Steiner ha scritto:
Hey,
Now that we have a number of loaders, I'd like to figure out a standard way of naming the libraries so that they are easy to organize and load. Currently, there are these arrangments:
pdXXX
pdlua.pd_linux pdtcl.pd_linux pdhaskell.pd_linux [import pdtcl]
XXXpd
luapd.pd_linux tclpd.pd_linux haskellpd.pd_linux [import tclpd]
XXX
lua.pd_linux tcl.pd_linux haskell.pd_linux [import tcl]
for me it's ok either "tclpd" or "pdtcl". I believe calling it just "tcl" would lead to confusion, since Tcl is already a library used by Pd.
if you happen to rename tclpd to pdtcl, please rename also the occurrences of tclpd inside the source code to pdtcl.
-- Federico Ferri
Using the "pd" afterwards means that they will sort alphabetically nicely. So how about this for the standard:
lua.pd_linux [import lua] project name: luapd
tcl.pd_linux [import tcl] project name: tclpd
Also, what about having a 'loaders' section of SVN? Either 'trunk/ loaders' or 'trunk/externals/loaders'? Then perhaps we don't need the 'pd' in the folder name:
trunk/loaders/clr trunk/loaders/hex trunk/loaders/libdir trunk/loaders/lua trunk/loaders/pd trunk/loaders/tcl
.hc
------------------------------------------------------------------------ ----
¡El pueblo unido jamás será vencido!