I was actually tempted to remove the EV_RST (its not handled, so what). But then I thought the #ifdef would be some sort of a warning that something actually has changed. In general everything should be "not handled" cleanly by the empyt default: switch.
Guenter
On Sun, 21 Mar 2004, Frank Barknecht wrote:
Hallo, Hans-Christoph Steiner hat gesagt: // Hans-Christoph Steiner wrote:
Have you seen any docs on this change from EV_RST to EV_SYN? I searched and didn't find anything. I am wondering why the change happened. A stable API would sure be nice. What is EV_RST or EV_SYN anyway? It looks likely that EV_SYN is just a new name for EV_RST, so an #ifdef selecting one or the other would probably make the most sense.
Sound sensible. I have no idea, what SYN or RST mean. probably they just mean: "nothing happening here currently..."
We could ask on linux-usb-devel for details.
ciao
Frank Barknecht _ ______footils.org__
PD-dev mailing list PD-dev@iem.at http://iem.at/cgi-bin/mailman/listinfo/pd-dev